Back to overview
Degraded

Creating new accounts is currently not working

Aug 05 at 02:00pm EDT
Affected services
Dashboard

Resolved
Aug 05 at 02:53pm EDT

Account creation using the new DNSHarmony plans is now working. There are still some bugs to sort out, if you need any help please contact our support.

Created
Aug 05 at 02:00pm EDT

We are currently having issues with the creation of new accounts. All other functionality on the Dashboard should be working as expected.